split Soekris profile into 45xx and 48xx, add kernel package for required watchdog...
[openwrt-10.03/.git] / target / linux / x86 / generic / profiles / Soekris45xx.mk
diff --git a/target/linux/x86/generic/profiles/Soekris45xx.mk b/target/linux/x86/generic/profiles/Soekris45xx.mk
new file mode 100644 (file)
index 0000000..a325517
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris45xx
+  NAME:=Soekris Net45xx
+  PACKAGES:=kmod-natsemi kmod-leds-net48xx kmod-sc520-wdt
+endef
+
+define Profile/Soekris45xx/Description
+        Package set compatible with the Soekris Net45xx. Net4511 and 4521 need PCMCIA Cardbus support. Please add manually.
+endef
+$(eval $(call Profile,Soekris45xx))