split Soekris profile into 45xx and 48xx, add kernel package for required watchdog...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Nov 2008 18:04:36 +0000 (18:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Nov 2008 18:04:36 +0000 (18:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13411 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk
target/linux/x86/generic/profiles/Soekris45xx.mk [new file with mode: 0644]
target/linux/x86/generic/profiles/Soekris48xx.mk [moved from target/linux/x86/generic/profiles/Soekris.mk with 68% similarity]

index 79b01c16c73dfeb5374657318830a03e354e0820..838526939f787ce47178a052c03eee6614b6bc77 100644 (file)
@@ -541,6 +541,22 @@ endef
 $(eval $(call KernelPackage,scx200-wdt))
 
 
+define KernelPackage/sc520-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Natsemi SC520 Watchdog support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_SC520_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
+endef
+
+define KernelPackage/sc520-wdt/description
+  Kernel module for SC520 Watchdog
+endef
+
+$(eval $(call KernelPackage,sc520-wdt))
+
+
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
diff --git a/target/linux/x86/generic/profiles/Soekris45xx.mk b/target/linux/x86/generic/profiles/Soekris45xx.mk
new file mode 100644 (file)
index 0000000..a325517
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris45xx
+  NAME:=Soekris Net45xx
+  PACKAGES:=kmod-natsemi kmod-leds-net48xx kmod-sc520-wdt
+endef
+
+define Profile/Soekris45xx/Description
+        Package set compatible with the Soekris Net45xx. Net4511 and 4521 need PCMCIA Cardbus support. Please add manually.
+endef
+$(eval $(call Profile,Soekris45xx))
similarity index 68%
rename from target/linux/x86/generic/profiles/Soekris.mk
rename to target/linux/x86/generic/profiles/Soekris48xx.mk
index 8cce126039b0b83a3875b246e7c8564d9ccbee38..e4d17fe520b249ae31b8d8cd096aacf9d3f12d66 100644 (file)
@@ -1,16 +1,16 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-define Profile/Soekris
-  NAME:=Soekris Net4801
+define Profile/Soekris48xx
+  NAME:=Soekris Net48xx
   PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-scx200-gpio kmod-scx200-wdt kmod-hwmon-pc87360
 endef
 
-define Profile/Soekris/Description
+define Profile/Soekris48xx/Description
         Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
 endef
-$(eval $(call Profile,Soekris))
+$(eval $(call Profile,Soekris48xx))