omap24xx: Append dtb to the zImage
[openwrt-working-2016/.git] / target / linux / omap24xx / image / Makefile
index 24e9b767443754ee14f6b4defd4e6e577d46bb91..316cce0f9f00cde31a04b0923e4ec193eb964043 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,10 +7,10 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-NAND_BLOCKSIZE=2048:128k
+NAND_BLOCKSIZE=2048-128k
 
 define Image/BuildKernel
-       $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+       cat $(KDIR)/zImage $(DTS_DIR)/omap2420-n810.dtb > $(BIN_DIR)/$(IMG_PREFIX)-zImage
        chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
 endef