[ixp4xx] move crypto module to target specific modules.mk
[openwrt-working-2016/.git] / target / linux / ixp4xx / modules.mk
index e088497793baf10565f1b0e0da2d3265d17a431a..8bf6e693b7893a2460d7ddb8377b4c7f4473f510 100644 (file)
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
 endef
 
 $(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+  TITLE:=Intel IXP4xx hardware crypto module
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:= \
+       CONFIG_CRYPTO_DEV_IXP4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+  $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+  Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))