brcm2708: add support for multi-device images
[openwrt-working-2016/.git] / target / linux / brcm2708 / bcm2708 / profiles / RaspberryPi.mk
index 82a7910ba1089e6c2c324139d1b18c6c42d5cd78..9f698a711d6f88395316048588c2862e0f0af465 100644 (file)
@@ -5,26 +5,10 @@
 # See /LICENSE for more information.
 #
 
-define Profile/Default
-  NAME:=Raspberry Pi
+define Profile/RaspberryPi
+  NAME:=Raspberry Pi Models B/B+/CM
 endef
-define Profile/Default/Description
-  Raspberry Pi
+define Profile/RaspberryPi/Description
+  Raspberry Pi Models B/B+/CM
 endef
-$(eval $(call Profile,Default))
-
-define Profile/RaspberryPi_B
-  NAME:=Raspberry Pi Model B
-endef
-define Profile/RaspberryPi_B/Description
-  Raspberry Pi Model B
-endef
-$(eval $(call Profile,RaspberryPi_B))
-
-define Profile/RaspberryPi_BPlus
-  NAME:=Raspberry Pi Model B+
-endef
-define Profile/RaspberryPi_BPlus/Description
-  Raspberry Pi Model B+
-endef
-$(eval $(call Profile,RaspberryPi_BPlus))
+$(eval $(call Profile,RaspberryPi))