linux/ar71xx: cosmetic fix for rb-711
[openwrt-working-2016/.git] / target / linux / au1000 / modules.mk
index cab44aa6cd574c7265c2cb5d1ef065337d5f575d..6b110531a5bc6b41732bd8b16f9c8f24a8050f11 100644 (file)
@@ -1,16 +1,17 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define KernelPackage/pcmcia-au1000
-  SUBMENU:=$(OTHER_MENU)
+  SUBMENU:=$(PCMCIA_MENU)
   TITLE:=RMI/AMD Au1000 PCMCIA support
-  DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
+  DEPENDS:=@TARGET_au1000 +kmod-pcmcia-core +kmod-pcmcia-rsrc
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/db1xxx_ss.ko
+  KCONFIG:=CONFIG_PCMCIA_ALCHEMY_DEVBOARD
+  AUTOLOAD:=$(call AutoLoad,41,db1xxx_ss)
 endef
 
 $(eval $(call KernelPackage,pcmcia-au1000))