package/kernel: move target specific modules to their own target files
[openwrt-working-2016/.git] / target / linux / au1000 / modules.mk
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
new file mode 100644 (file)
index 0000000..cab44aa
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/pcmcia-au1000
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RMI/AMD Au1000 PCMCIA support
+  DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
+endef
+
+$(eval $(call KernelPackage,pcmcia-au1000))