Hopefully fix the PCI resource conflict and upgrade to .24.2
[openwrt-10.03/.git] / target / linux / au1000 / Makefile
index d7b9f739ab7f6fa2b953555f53456fa21d2f0b79..4566d6c4cb871d776da730d9688f181746ebc437 100644 (file)
@@ -11,24 +11,21 @@ BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.24.2
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += yamonenv
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += yamonenv
-
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))