ar71xx: on wnr2200, revert the mac0/mac1, the ethernet interfaces are swapped. use...
[openwrt-working-2016/.git] / target / linux / ar71xx / patches-4.1 / 912-MIPS-ath79-add-gl_ar300.patch
index 6ca9913b2d78674e9e170505073d2baf3f1b3749..e9c0f4f14244429b01ed136d9c3830d0048855c7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -587,6 +587,16 @@ config ATH79_MACH_GL_AR150
+@@ -596,6 +596,16 @@ config ATH79_MACH_GL_AR150
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
@@ -19,7 +19,7 @@
        select SOC_AR933X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -84,6 +84,7 @@ obj-$(CONFIG_ATH79_MACH_EPG5000)     += mach
+@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_EPG5000)     += mach
  obj-$(CONFIG_ATH79_MACH_ESR1750)      += mach-esr1750.o
  obj-$(CONFIG_ATH79_MACH_F9K1115V2)    += mach-f9k1115v2.o
  obj-$(CONFIG_ATH79_MACH_GL_AR150)   += mach-gl-ar150.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_GS_OOLITE)    += mach-gs-oolite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -73,6 +73,7 @@ enum ath79_mach_type {
+@@ -74,6 +74,7 @@ enum ath79_mach_type {
        ATH79_MACH_EPG5000,             /* EnGenius EPG5000 */
        ATH79_MACH_F9K1115V2,           /* Belkin AC1750DB */
        ATH79_MACH_GL_AR150,    /* GL-AR150 support */