standardize Makefile, change section from base to utils
[openwrt-10.03/.git] / package / udev / Makefile
index 5d397161b199c28ae9e839422798b2766a7aa865..e942442032f4405ccf545074b4a422679547c1d2 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -19,21 +25,21 @@ PKG_CAT:=bzcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/udev
-SECTION:=base
-DEPENDS:=@LINUX_2_6
-TITLE:=Dynamic device management subsystem
-DESCRIPTION:=udev provides a dynamic device directory containing only the files for \\\
-actually present devices. It creates or removes device node files in \\\
-the /dev directory, or it renames network interfaces. \\\
-URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Dynamic device management subsystem
+  DESCRIPTION:=\
+       udev provides a dynamic device directory containing only the files for \\\
+       actually present devices. It creates or removes device node files in \\\
+       the /dev directory, or it renames network interfaces.
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS="$(TARGET_CROSS)" \
                STRIP="/bin/true" \