lldpd: upgrade to 0.7.1
[openwrt-working-2016/.git] / package / network / services / lldpd / Makefile
index 0e62e35338e587cf5d78ce98c2cf1baff90b8fb7..024116c3f76cdad158fcca7defb58bce7de5b246 100644 (file)
@@ -8,18 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.6.0
+PKG_VERSION:=0.7.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=77279577e3b6d85a33dc0afe7c960b27
+PKG_MD5SUM:=cee0e2ae7d4b8bf25ae234d9536052b8
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
+TARGET_CFLAGS+=--std=c99
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lldpd
@@ -43,8 +45,9 @@ endef
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lldp{ctl,d} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{ctl,d} $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
        $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
 endef
@@ -53,4 +56,9 @@ define Package/lldpd/conffiles
 /etc/config/lldpd
 endef
 
+CONFIGURE_ARGS += \
+       --with-privsep-user=lldp \
+       --with-privsep-group=lldp \
+       --with-privsep-chroot=/var/run/lldp
+
 $(eval $(call BuildPackage,lldpd))