ltq-vdsl: force shell to bash to avoid compile errors
[openwrt-working-2016/.git] / package / kernel / lantiq / ltq-vdsl / Makefile
index e94692771b7fdb916e8ff8e4f00a626a2c4c7233..d14d4bc95558aa2286c8d8e16afa29f436dcaade 100644 (file)
@@ -16,6 +16,8 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/drv_dsl_cpe_api-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
 PKG_MD5SUM:=b6d9c1e3c5db1bfcd6e81bb2f582cadb
 
+PKG_USE_MIPS16:=0
+
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 include $(INCLUDE_DIR)/package.mk
@@ -38,6 +40,9 @@ endef
 
 EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
 
+MAKE_FLAGS += \
+       SHELL="$(BASH)"
+
 CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
        --with-max-device="1" \
        --with-lines-per-device="1" \