lantiq: fix gcc 5 build
[openwrt-working-2016/.git] / package / kernel / lantiq / ltq-adsl / Makefile
index 154dc52741b675e54f94d7d79b5362b02fb5170c..26c931e2a92cc1577a3139ca00ae5111cab5e21f 100644 (file)
@@ -18,6 +18,8 @@ PKG_MD5SUM:=c45bc531c1ed2ac80f68fb986b63bb87
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 PKG_USE_MIPS16:=0
+PKG_CHECK_FORMAT_SECURITY:=0
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -83,11 +85,6 @@ endif
 
 EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/adsl
        $(CP) $(PKG_BUILD_DIR)/src/include/drv_dsl_cpe_*.h $(1)/usr/include/adsl/