install missing ebtables files
[openwrt-10.03/.git] / package / ebtables / Makefile
index 04bb99d15764c1795070f33b7cfd0c460abe58ad..f4359a6675d56e8f9c7482104fa5003d7f5cca6d 100644 (file)
@@ -3,13 +3,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ebtables
-PKG_VERSION:=2.0.6
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.8-rc2
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
+PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
 PKG_CAT:=zcat
 
 include $(TOPDIR)/package/rules.mk
@@ -25,8 +25,13 @@ endef
 define Package/ebtables/install
        install -d -m0755 $(1)/etc
        install -m0644 $(PKG_BUILD_DIR)/ethertypes $(1)/etc/
+       install -d -m0755 $(1)/usr/lib/ebtables
+       install -m0755 $(PKG_BUILD_DIR)/lib*.so $(1)/usr/lib/
+       install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(1)/usr/lib/ebtables/
        install -d -m0755 $(1)/usr/sbin
        install -m0755 $(PKG_BUILD_DIR)/ebtables $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ebtables))