perf: fix musl compatibility
[openwrt-working-2016/.git] / package / devel / perf / Makefile
index d6db053173bbb4b6f1ba563386a3dac8c3b2731d..c999229324a2742cd58956f10e54bb7253195fed 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= @!USE_UCLIBC +libelf1 +libdw +libpthread +librt +binutils
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -57,6 +57,10 @@ MAKE_FLAGS = \
        WERROR=0 \
        prefix=/usr
 
+ifdef CONFIG_USE_MUSL
+ MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
+
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
                -C $(PKG_BUILD_DIR) \