perf: don't error on warnings
[openwrt-working-2016/.git] / package / devel / perf / Makefile
index 184e51d696e50875c9109e0d1b3eb5e8e86e6d6e..1e874243b31a1c93b8814fed103b93022bc97ec7 100644 (file)
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -55,6 +55,7 @@ MAKE_FLAGS = \
        LD="$(TARGET_CROSS)ld" \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
+       WERROR=0 \
        V=1 \
        prefix=/usr