linux/ar71xx: cosmetic fix for rb-711
[openwrt-working-2016/.git] / package / boot / uboot-oxnas / Makefile
index 42f3cf9f1a551c49523035480581052770cc4da7..825907b6308245f52b6baab2307283472ee2804b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2014.04
+PKG_VERSION:=2014.10
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -18,7 +18,10 @@ PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
 
-PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
+
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -79,6 +82,8 @@ define Package/uboot/install/default
        $(INSTALL_DIR) $(BIN_DIR)
        $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
                $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
+       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
+               $(KERNEL_BUILD_DIR)/u-boot.bin
 endef
 
 define Package/uboot/install/template