Add yamonenv, utility to read and configure variables for the YAMON bootloader
[openwrt-10.03/.git] / include / package.mk
index cf8756ea63ecb58811947b07509099222913702c..bf2376dcd02ce6724f86d9d05370a227134939dc 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 ifneq ($(DUMP),)
   all: dumpinfo
 else
@@ -74,6 +80,7 @@ define Package/Default
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
+  SUBMENU:=
   TITLE:=
   DESCRIPTION:=
 endef
@@ -124,6 +131,11 @@ define BuildPackage
        echo "Menu: $(MENU)";
   endif
 
+  ifneq ($(SUBMENU),)
+    DUMPINFO += \
+       echo "Submenu: $(SUBMENU)";
+  endif
+
   ifneq ($(DEFAULT),)
     DUMPINFO += \
        echo "Default: $(DEFAULT)";