Add yamonenv, utility to read and configure variables for the YAMON bootloader
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Jul 2006 13:25:25 +0000 (13:25 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Jul 2006 13:25:25 +0000 (13:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4116 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/yamonenv/Makefile [new file with mode: 0644]

diff --git a/package/yamonenv/Makefile b/package/yamonenv/Makefile
new file mode 100644 (file)
index 0000000..dfb0c82
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yamonenv
+PKG_VERSION:=20051022
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE:=$(PKG_NAME)_gruen.4g__$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://meshcube.org/nylon/stable/sources/
+PKG_MD5SUM:=a3e4f24155aa3ba5aa502bc63fdaa6ad
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/yamonenv
+SECTION:=sys
+CATEGORY:=Base system
+DEPENDS:=@LINUX_2_6_AU1000@
+TITLE:=YAMON configuration utility
+DESCRIPTION:=YAMON bootloader configuration utility
+URL:=http://meshcube.org/nylon/stable/sources/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default,all)
+endef
+
+define Package/yamonenv/install
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,yamonenv))