Port arptables to -ng
[openwrt-10.03/.git] / include / kernel.mk
index 8492998020c000d926db8be4fc3087ac47d48d51..318ca6869dc0d3012a47f09a50e850996935b03a 100644 (file)
@@ -1,9 +1,15 @@
-KERNEL:=kernel
-BOARD:=board
-LINUX_VERSION:=kernel
-
-ifneq ($(DUMP),1)
-include $(TOPDIR)/.kernel.mk
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ifeq ($(DUMP),1)
+  KERNEL:=<KERNEL>
+  BOARD:=<BOARD>
+  LINUX_VERSION:=<LINUX_VERSION>
+else
+-include $(TOPDIR)/.kernel.mk
 
 ifneq (,$(findstring 2.4.,$(LINUX_VERSION)))
 KERNEL:=2.4
@@ -22,6 +28,11 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/armeb/arm/' \
 )
 
+ifneq (,$(findstring uml,$(BOARD)))
+LINUX_KARCH="um"
+KERNEL_CROSS=
+endif
+
 KERNEL_BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 LINUX_DIR := $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 
@@ -47,10 +58,10 @@ PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)_
 I_$(1) := $(KMOD_BUILD_DIR)/ipkg/$(2)
 
 ifeq ($$(KDEPEND_$(1)),m)
-ifneq ($(CONFIG_PACKAGE_KMOD_$(1)),)
+ifneq ($$(CONFIG_PACKAGE_KMOD_$(1)),)
 TARGETS += $$(PKG_$(1))
 endif
-ifeq ($(CONFIG_PACKAGE_KMOD_$(1)),y)
+ifeq ($$(CONFIG_PACKAGE_KMOD_$(1)),y)
 INSTALL_TARGETS += $$(PKG_$(1))
 endif
 endif