ath79: add support for Ubiquiti ToughSwitch/EdgeSwitch 8XP
[openwrt/.git] / target / linux / ath79 / image / generic-ubnt.mk
index f6546f369eb81857ffa01d02a67661a2cced8285..87e7f5cc32dc36b4f09ce73b157cb0a05e1f0fc1 100644 (file)
@@ -129,6 +129,13 @@ define Device/ubnt_bullet-m-xw
 endef
 TARGET_DEVICES += ubnt_bullet-m-xw
 
+define Device/ubnt_edgeswitch-8xp
+  $(Device/ubnt-sw)
+  DEVICE_MODEL := EdgeSwitch 8XP
+  DEVICE_PACKAGES += switch-bcm53xx-mdio
+endef
+TARGET_DEVICES += ubnt_edgeswitch-8xp
+
 define Device/ubnt_lap-120
   $(Device/ubnt-wa)
   DEVICE_MODEL := LiteAP ac