Merge branch 'master' into ozonet
[openwrt/.git] / package / devel / perf / Makefile
index 3bb403916bfec892ee917719e05c146660f3a26f..8a425754a1010aca50d0a1840cec7580fbd90618 100644 (file)
@@ -62,6 +62,12 @@ MAKE_FLAGS = \
        O=$(PKG_BUILD_DIR) \
        prefix=/usr
 
+ifdef CONFIG_LINUX_4_4
+ifdef CONFIG_USE_MUSL
+ MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
+endif
+
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
                --no-print-directory \