image/lzma-loader: preserve MIPS abiflags
authoracoul <alex@ozo.com>
Mon, 28 Dec 2015 21:03:42 +0000 (23:03 +0200)
committeracoul <alex@ozo.com>
Thu, 31 Mar 2016 05:28:36 +0000 (08:28 +0300)
target/linux/generic/image/lzma-loader/src/Makefile

index 910172c4f8963ba9d362f05620d3aaf5aa5b5d80..707876802972fb1e98e45325e3cf3427ff7904be 100644 (file)
@@ -12,7 +12,7 @@ IMAGE_COPY:=0
 
 CROSS_COMPILE = mips-linux-
 
-OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -R .MIPS.abiflags -S
 CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSTART=${RAMSTART} -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
 ifeq ($(IMAGE_COPY),1)
 CFLAGS += -DLOADADDR=${LOADADDR} -DIMAGE_COPY=1