netifd: fix default ORO for 6rd
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2014 12:27:41 +0000 (12:27 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2014 12:27:41 +0000 (12:27 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@43215 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/config/netifd/Makefile
package/network/config/netifd/files/lib/netifd/proto/dhcp.sh

index f4bd6be5496b92b56f03fe3d4fd8eb7c324af88e..be0114f4557b6c0af274bab5abc8f9e1fc8ad644 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2014-09-08
+PKG_VERSION:=2014-09-08.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index b14f7be92dcd61fa6bad39ea6248b0a97c530259..406746067598d01065452ab687da1733ba829763 100755 (executable)
@@ -39,7 +39,7 @@ proto_dhcp_setup() {
        [ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
        [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
        [ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
-       [ -n "$iface6rd" ] && append dhcpopts "-O 212"
+       [ "$iface6rd" != 0 -a -f /lib/netifd/proto/6rd.sh ] && append dhcpopts "-O 212"
        [ -n "$zone6rd" ] && proto_export "ZONE6RD=$zone6rd"
        [ -n "$zone" ] && proto_export "ZONE=$zone"
        [ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"