BB: kernel: kmod-scsi-core: fix load on install
[openwrt-14.07/.git] / package / kernel / linux / modules / block.mk
index 8a84aa4e22290969fabfb75f0494006000c8460a..8c29e01ad14de3f9bfe6cdbf473a9032993671e6 100644 (file)
@@ -565,9 +565,9 @@ define KernelPackage/scsi-core
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
   FILES:= \
-       $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+       $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
        $(LINUX_DIR)/drivers/scsi/sd_mod.ko
-  AUTOLOAD:=$(call AutoLoad,40,sd_mod,1)
+  AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
 endef
 
 $(eval $(call KernelPackage,scsi-core))