add some extra stripping options for kernel modules to reduce size even more (thx...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Oct 2009 16:26:12 +0000 (16:26 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Oct 2009 16:26:12 +0000 (16:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18121 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index 20cb85e3047f269482cb7d6e07139666c5c7403a..536f8cff7fc26bbc0692a670e1daec1b8e8d8237 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -183,7 +183,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=mdebug.abi32" \
     $(SCRIPT_DIR)/rstrip.sh
 endif