[package] kernel: add missing CONFIG_SND_SOC_ALL_CODECS to kmod-sound-soc-core KCONFIG
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Mar 2010 09:12:44 +0000 (09:12 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Mar 2010 09:12:44 +0000 (09:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20133 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 1f2cc4e7497d9fbd6f7d3ff892791afbdc65dd65..e4a4c73cfbe0fa525a625c0cd9b630a5be16eebc 100644 (file)
@@ -133,10 +133,13 @@ endef
 
 $(eval $(call KernelPackage,sound-cs5535audio))
 
+
 define KernelPackage/sound-soc-core
 $(call KernelPackage/sound/Depends)
   TITLE:=SoC sound support
-  KCONFIG:=CONFIG_SND_SOC
+  KCONFIG:= \
+       CONFIG_SND_SOC \
+       CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
   AUTOLOAD:=$(call AutoLoad,35, snd-soc-core)
 endef