ar71xx: create rescue image for the WZR-HP-G300NH
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 16:46:57 +0000 (16:46 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 16:46:57 +0000 (16:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19223 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index d3baec69e1eef950bd5be9e2f894859a46ff3c7f..09d743c479d5421c1e82c557103b3bd44775d3ab 100644 (file)
@@ -129,6 +129,10 @@ define Image/Build/WZRHPG300NH
                        dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
                        dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
                ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+               ( \
+                       echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+                       dd if=$(call imgname,$(1),$(2))-sysupgrade.bin; \
+               ) > $(call imgname,$(1),$(2))-tftp.bin; \
        fi; fi
 endef