only run svn info if .svn exists
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 03:37:31 +0000 (03:37 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 03:37:31 +0000 (03:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9213 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk

index a9ca3a2806ff9955219d3797794547231211c485..3e391653490d99ef4936b990698e1df459352373 100644 (file)
@@ -16,7 +16,7 @@ include $(TOPDIR)/include/verbose.mk
 ifneq ($(VERSION),)
   OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
   ifneq ($(REV),)
     OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
   endif