avoid kernel version in target if sub-targets available
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Feb 2009 10:32:45 +0000 (10:32 +0000)
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Feb 2009 10:32:45 +0000 (10:32 +0000)
(usefull if we have 2.4 and 2.6 sub-targets in parallel)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14576 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index 7351794dce9d6601ed72561a20a82a5aab1955cf..ee373aa19e0de3926c5934ed1a128980aefc05e4 100644 (file)
@@ -154,7 +154,7 @@ define BuildTargets/DumpCurrent
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
         echo 'Target-Kernel: $(KERNEL)'; \
-        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGET),, [$(KERNEL)])'; \
+        echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),, [$(KERNEL)])$(if $(SUBTARGETS),$(if $(SUBTARGET), [$(KERNEL)]))'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \