[ar71xx] tew-632brp: use LZMA compressed uImage
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Dec 2008 08:32:04 +0000 (08:32 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Dec 2008 08:32:04 +0000 (08:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13645 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
target/linux/ar71xx/image/Makefile

index c162913903c9e4b126bdff68bafb937be94b74f7..c736b79516af57805fdbd7d349db1ac2f411c8a3 100644 (file)
@@ -34,20 +34,20 @@ static struct mtd_partition tew_632brp_partitions[] = {
        } , {
                .name           = "kernel",
                .offset         = 0x030000,
-               .size           = 0x100000,
+               .size           = 0x0c0000,
        } , {
                .name           = "rootfs",
-               .offset         = 0x130000,
-               .size           = 0x2b0000,
-       } , {
-               .name           = "firmware",
-               .offset         = 0x030000,
-               .size           = 0x3b0000,
+               .offset         = 0x0f0000,
+               .size           = 0x2f0000,
        } , {
                .name           = "art",
                .offset         = 0x3e0000,
                .size           = 0x020000,
                .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "firmware",
+               .offset         = 0x030000,
+               .size           = 0x3b0000,
        }
 };
 #endif /* CONFIG_MTD_PARTITIONS */
index a9c7dd679ffda26931423b385c340f391231917d..3950b0b52ee96063a439e87a731d9aee6533b915 100644 (file)
@@ -39,14 +39,14 @@ endef
 define Image/Build/AP81
        cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
-       gzip -9 -c $(KDIR)/vmlinux-$(2) > $(KDIR)/vmlinux-$(2).bin.gz
-       mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+       mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
                0x80060000 \
                -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-               -d $(KDIR)/vmlinux-$(2).bin.gz $(KDIR)/vmlinux-$(2).uImage
+               -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage
        ( \
-               dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
-               dd if=$(KDIR)/root.$(1) bs=2752k conv=sync; \
+               dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
+               dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
        ) > $(call imgname,$(1),$(2)).bin
        cp $(call imgname,$(1),$(2)).bin $(call imgname,$(1),$(2)).webui
        echo -n $(4) >> $(call imgname,$(1),$(2)).webui