Fix the tgz image build
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jul 2007 14:40:57 +0000 (14:40 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jul 2007 14:40:57 +0000 (14:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8042 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
target/linux/adm5120-2.6/image/Makefile

index 5fc87efa1d951e8d0127feb7fff688ca45bf918c..c56e7cf193618b6b5b7cd82b2cde7a111e6f6a16 100644 (file)
@@ -57,6 +57,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
                $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
+               $(call Image/Build,tgz)
     endef
   endif
 else
index d76e1e1feeb1a39642f08a66a8a2ae4a32da3a35..b9ae44ecb41cb1307be0fe90ac7d3e25993cdaa5 100644 (file)
@@ -90,6 +90,7 @@ define Image/Build
 # this line is here intentionally
 ifneq ($(1),jffs2-256k)
 ifneq ($(1),jffs2-128k)
+ifneq ($(1),tgz)
        $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
 ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
@@ -119,6 +120,7 @@ ifeq ($(CONFIG_DEVEL),y)
 endif
 endif
 endif
+endif
 ifeq ($(1),tgz)
        $(call Image/Build/RouterBoard)
 endif