gcc: fix build with cloog/ppl
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2009 00:47:27 +0000 (00:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2009 00:47:27 +0000 (00:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18266 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile

index 77243c5fa4bd2c45853a5bee0278b2a5062ed19b..9d865e94d3e439e65972811c4b362e0db919690f 100644 (file)
@@ -90,6 +90,7 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
+               $(if $(CONFIG_GCC_VERSION_4_4),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \