Add default /etc/dnsmasq.conf
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2009 13:25:11 +0000 (13:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2009 13:25:11 +0000 (13:25 +0000)
dnsmasq allows adding of arbitrary SRV/PTR/TXT/CNAME records.
However, those options sometimes can not be passed as
command-line arguments due to excess length.  This patch tries to
solve this problem:

1. Provide /etc/dnsmasq.conf file with comments about adding
   SRV/PTR/TXT/CNAME records.
2. Add this file to conffiles list so it is preserver during
   backup/restore or system upgrade.

If someone needs a lot of custom records, default configuration
file can be edited.  Since manual pages and documentation is not
installed, provided comments should be enough to figure out
option syntax.

Signed-off-by: Alexey I. Froloff <raorn@altlinux.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17663 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.conf [new file with mode: 0644]

index 3444efefff043c7a8d888e98cfeda1d682c791c4..176e5b93d322e9e6fefcf75f9b0c007e2c26f705 100644 (file)
@@ -30,6 +30,7 @@ endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
 define Build/Compile
@@ -46,6 +47,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef
diff --git a/package/dnsmasq/files/dnsmasq.conf b/package/dnsmasq/files/dnsmasq.conf
new file mode 100644 (file)
index 0000000..bf5816b
--- /dev/null
@@ -0,0 +1,37 @@
+# Change the following lines if you want dnsmasq to serve SRV
+# records.
+# You may add multiple srv-host lines.
+# The fields are <name>,<target>,<port>,<priority>,<weight>
+
+# A SRV record sending LDAP for the example.com domain to
+# ldapserver.example.com port 289
+#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389
+
+# Two SRV records for LDAP, each with different priorities
+#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389,1
+#srv-host=_ldap._tcp.example.com,ldapserver.example.com,389,2
+
+# A SRV record indicating that there is no LDAP server for the domain
+# example.com
+#srv-host=_ldap._tcp.example.com
+
+# The following line shows how to make dnsmasq serve an arbitrary PTR
+# record. This is useful for DNS-SD.
+# The fields are <name>,<target>
+#ptr-record=_http._tcp.dns-sd-services,"New Employee Page._http._tcp.dns-sd-services"
+
+# Change the following lines to enable dnsmasq to serve TXT records.
+# These are used for things like SPF and zeroconf.
+# The fields are <name>,<text>,<text>...
+
+#Example SPF.
+#txt-record=example.com,"v=spf1 a -all"
+
+#Example zeroconf
+#txt-record=_http._tcp.example.com,name=value,paper=A4
+
+# Provide an alias for a "local" DNS name. Note that this _only_ works
+# for targets which are names from DHCP or /etc/hosts. Give host
+# "bert" another name, bertrand
+# The fields are <cname>,<target>
+#cname=bertand,bert