The attached patch replaces $(1) install by $(if $(1), $(1),
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Mar 2010 20:19:48 +0000 (20:19 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Mar 2010 20:19:48 +0000 (20:19 +0000)
install) in the definition, in order to be able to specify an install
rule, which is not always called install (example:
trunk/package/ncurses/Makefile has rules called install.libs and install.data).

Then its possible to do this in ncurses Makefile:

define Build/Install
       $(call Build/Install/Default, install.libs install.data)
endef

This patch does not affect anything else, as if no parameter is given,
it will use install as before.

-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19996 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-defaults.mk

index 017a86d1e8d0d4309d10602093be10aa90b16d1e..ecc3af499fd27ce0a0c2533cba4003358eb65a91 100644 (file)
@@ -122,7 +122,7 @@ define Build/Install/Default
        $(MAKE_VARS) \
        $(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
                $(MAKE_INSTALL_FLAGS) \
        $(MAKE_VARS) \
        $(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
                $(MAKE_INSTALL_FLAGS) \
-               $(1) install;
+               $(if $(1), $(1), install);
 endef
 
 define Build/Dist/Default
 endef
 
 define Build/Dist/Default