store the default kernel version for our ports in a single place (target makefiles...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Dec 2006 09:12:57 +0000 (09:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Dec 2006 09:12:57 +0000 (09:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5899 3c298f89-4303-0410-b956-a3cf2f4a3e73

16 files changed:
include/kernel-build.mk
include/kernel-version.mk [new file with mode: 0644]
target/linux/ar7-2.4/Makefile
target/linux/aruba-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/au1000-2.6/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.6/Makefile
target/linux/brcm63xx-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/rdc-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index 6643d46586a735572fe287a32f7716c4e21fe535..6d9c9d978d17ebdf34817919c80043c40ab6bc5e 100644 (file)
@@ -33,8 +33,8 @@ ifeq ($(DUMP),1)
 else
   all: compile
 endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
+include $(INCLUDE_DIR)/kernel-version.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/kernel.mk
 
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
new file mode 100644 (file)
index 0000000..af457a2
--- /dev/null
@@ -0,0 +1,15 @@
+# Use the default kernel version if the Makefile doesn't override it
+
+ifeq ($(LINUX_VERSION),)
+  ifeq ($(KERNEL),2.4)
+    LINUX_VERSION:=2.4.33.4
+    LINUX_RELEASE:=1
+    LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+  else
+    LINUX_VERSION:=2.6.19.1
+    LINUX_RELEASE:=1
+    LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
+  endif
+endif
+KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+
index f9d3290b623851bcd4887121b420abc5ef9bd156..970bb4bbdf7d26d919867daa94406fe8654c5286 100644 (file)
@@ -15,9 +15,7 @@ define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
 endef
 
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-avalanche-cpmac
index 989f321b062623cd7baaeca74bb7502499a09dab..5d3e19ea2f514fdba1c16ec41250cd5b0d7e872a 100644 (file)
@@ -15,10 +15,6 @@ define Target/Description
        Build firmware images for Aruba boards
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
index f3f3ca6b4e8bcee7dc0b70e7a6f6438e40564dc9..92f9d361c4f492ff7e9005b22e2d81fee4c0d6c2 100644 (file)
@@ -15,10 +15,6 @@ define Target/Description
        Build firmware images for Atheros SoC boards (currently AR2315-AR2317)
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
index 4b20032f95124e123621419933ff8ce19e6b5fd0..2f2a92b0e12d7b13323ed3fe03fb7724180492c2 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Kernel/BuildImage
index 226da5623e87a7f6ef7d671df1ae4c07a5da5223..4e1267df352eafa32c8f438dbcc980eac52f0720 100644 (file)
@@ -20,9 +20,7 @@ define Target/Description
        with TFTP client too.
 endef
 
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch nvram
index c30e150f4af60d67c3202d4cccf6f5181e8fab19..8e69332c2865707487bc0da070b3037c36d4dc65 100644 (file)
@@ -20,10 +20,6 @@ define Target/Description
        with TFTP client too.
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch
 
index 4757eff89943f85d1d7f17d1b838c3e6cf671170..5b98e909c33dc77224d78d4f7a40dda04cd966c7 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Profile/Broadcom
index 1d08708a3283f0a5dbc5194cdd2c72081c32b9eb..352671ee69e6d63593eca6d92bbdeed941f41b16 100644 (file)
@@ -14,9 +14,5 @@ FEATURES:=jffs2
 define Target/Description
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index 0dcc1e7c14d6cbf72f0923fa1b1e048453b96273..b829965a50e3afc600e6649123a5d8414ababbed 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=jffs2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index ae28b87afe5de2bf2e0abcbd8fc3cf3b6044af13..6ec9bdcd38f25c81287827ffdb3318986928c718 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index 3fbd700c347539014e34e3f823c8fc243e194152..f1f751eee6732ebee3317080743de74e6174dfff 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Profile/Ralink
index 2dd590c5ac6e0e547110c753510b000c156ab79c..364d116d4d4593057a2697e9d777bacf4610dca0 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=sibyte
 BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index ff2297f3c872026e55f0a50bd900a41dcfbc761e..33bf8060fef7806235de104d10c87642ce34079b 100644 (file)
@@ -10,9 +10,5 @@ ARCH:=i386
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index f7e3fa83730ea02664e4e36c8b3d724ca2d4307c..25e7356877c8a8df667c8ea7bf359c897c30a860 100644 (file)
@@ -11,10 +11,6 @@ BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=jffs2 ext2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 $(eval $(call BuildKernel))