[ar71xx] tew-632brp: increase the size of rootfs partition, and build one unified...
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Mar 2009 11:17:16 +0000 (11:17 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Mar 2009 11:17:16 +0000 (11:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14709 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
target/linux/ar71xx/image/Makefile

index 8235a6dd0feab563d5abdb4c7ee1e939498e2258..c3fc2b212d2a2d77f8dbc78a584e267b65a71afb 100644 (file)
@@ -48,16 +48,16 @@ static struct mtd_partition tew_632brp_partitions[] = {
        } , {
                .name           = "rootfs",
                .offset         = 0x0f0000,
-               .size           = 0x2f0000,
+               .size           = 0x300000,
        } , {
                .name           = "art",
-               .offset         = 0x3e0000,
-               .size           = 0x020000,
+               .offset         = 0x3f0000,
+               .size           = 0x010000,
                .mask_flags     = MTD_WRITEABLE,
        } , {
                .name           = "firmware",
                .offset         = 0x030000,
-               .size           = 0x3b0000,
+               .size           = 0x3c0000,
        }
 };
 #endif /* CONFIG_MTD_PARTITIONS */
index c861dce25bdc780ab42b0b856bc7972849d71ecb..4a226084fb977f3ca98379d68e4be96eb45d15f2 100644 (file)
@@ -52,9 +52,8 @@ define Image/Build/AP81
                ( \
                        dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
                        dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
-               ) > $(call imgname,$(1),$(2)).bin; \
-               cp $(call imgname,$(1),$(2)).bin $(call imgname,$(1),$(2)).webui; \
-               echo -n $(4) >> $(call imgname,$(1),$(2)).webui; \
+                       echo -n $(4); \
+               ) > $(call imgname,$(1),$(2)).uni; \
        fi; fi
 endef