strip kernel modules automatically as well
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 31 May 2006 20:06:46 +0000 (20:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 31 May 2006 20:06:46 +0000 (20:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3870 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk
scripts/rstrip.sh

index a613beaf40be3daa40e95b726597b79d1e3fa555..a94eee9cd1c15319c5a04d831f51b7045aa1fe56 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -110,9 +110,7 @@ IPKG_TARGET_DIR := $(PACKAGE_DIR)
 IPKG:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(STAGING_DIR)/etc IPKG_OFFLINE_ROOT=$(BUILD_DIR)/root $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
 IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
 
-RSTRIP:=STRIP="$(STRIP)" $(SCRIPT_DIR)/rstrip.sh
-RSTRIP_KMOD:=STRIP="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
-
+RSTRIP:=STRIP="$(STRIP)" STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
 
 all:
 .PHONY: FORCE
index 023ae4e54fdc8aa1ab945a4acd98be112e6498b2..f71aaaf4f9ff2792d402715e40bd172ec495799a 100755 (executable)
@@ -15,12 +15,14 @@ TARGETS=$*
   exit 1
 }
 
-find $TARGETS -type f -not -name \*.o -not -name \*.ko -a -exec file {} \; | \
+find $TARGETS -type f -a -exec file {} \; | \
   sed -n -e 's/^\(.*\):.*ELF.*\(executable\|relocatable\|shared object\).*, not stripped/\1:\2/p' | \
 (
   IFS=":"
   while read F S; do
     echo "$SELF: $F:$S"
-    eval "$STRIP $F"
+       [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && \
+               eval "$STRIP_KMOD $F" || \
+               eval "$STRIP $F"
   done
 )