move the common variables from host-build.mk to host.mk
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 16:58:47 +0000 (16:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 16:58:47 +0000 (16:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5021 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/host.mk [new file with mode: 0644]

index 5670b6f17db78992e10a8a5e95fedeeafb9c29ed..a1287da475bc8a63a5d13c021e6d27efc0fe39e9 100644 (file)
@@ -5,24 +5,7 @@
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
-
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host-build.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-
+include $(INCLUDE_DIR)/host.mk
 
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
diff --git a/include/host.mk b/include/host.mk
new file mode 100644 (file)
index 0000000..b4580e2
--- /dev/null
@@ -0,0 +1,24 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/.host.mk
+
+$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+       echo "HOST_OS:=`uname`" > $@
+       echo "HOST_ARCH:=` \
+               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+                       -e 's/sparc.*/sparc/' \
+                       -e 's/arm.*/arm/' \
+                       -e 's/m68k.*/m68k/' \
+                       -e 's/ppc/powerpc/' \
+                       -e 's/v850.*/v850/' \
+                       -e 's/sh[234]/sh/' \
+                       -e 's/mips-.*/mips/' \
+                       -e 's/mipsel-.*/mipsel/' \
+                       -e 's/cris.*/cris/' \
+                       -e 's/i[3-9]86/i386/'`" >> $@
+       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@