Drop changes to mm/fault.c prevents from seeing kernel oops while restarting the...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Oct 2006 23:41:00 +0000 (23:41 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Oct 2006 23:41:00 +0000 (23:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5141 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc-2.6/patches/000-rdc_fixes.patch

index 4a75f5fca1378243e99eaed2984d992dfd30de46..5e3878d08fc0235155b91865f6ac6f663f0f86a4 100644 (file)
@@ -835,27 +835,3 @@ diff -urN linux-2.6.17/arch/i386/Makefile linux-2.6.17.new/arch/i386/Makefile
  
  # default subarch .h files
  mflags-y += -Iinclude/asm-i386/mach-default
-diff -urN linux-2.6.17/arch/i386/mm/fault.c linux-2.6.17.new/arch/i386/mm/fault.c
---- linux-2.6.17/arch/i386/mm/fault.c  2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/arch/i386/mm/fault.c      2006-10-07 22:24:15.000000000 +0200
-@@ -551,6 +551,7 @@
-       tsk->thread.cr2 = address;
-       tsk->thread.trap_no = 14;
-       tsk->thread.error_code = error_code;
-+      machine_restart(NULL); /* Added for RDC */
-       die("Oops", regs, error_code);
-       bust_spinlocks(0);
-       do_exit(SIGKILL);
-@@ -566,6 +567,12 @@
-               down_read(&mm->mmap_sem);
-               goto survive;
-       }
-+      /* RDC : Forcing processes to be niced */
-+      if (tsk->prio < 0) {
-+              printk("VM: niced process %s\n", tsk->comm);
-+              yield();
-+              goto survive;
-+      }
-       printk("VM: killing process %s\n", tsk->comm);
-       if (error_code & 4)
-               do_exit(SIGKILL);