[ifxmips] prepare kernel for voip
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Mar 2010 21:06:27 +0000 (21:06 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Mar 2010 21:06:27 +0000 (21:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20613 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ifxmips/Makefile
target/linux/ifxmips/extract.py [new file with mode: 0755]
target/linux/ifxmips/extract.sh [new file with mode: 0755]
target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
target/linux/ifxmips/files/arch/mips/ifxmips/timer.c

index addeef681096f7124698a2ba424d3273af844391..b82f78263f8f636f0c7ddd7dbed4d4f09602b686 100644 (file)
@@ -16,7 +16,8 @@ LINUX_VERSION:=2.6.30.10
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control
+DEFAULT_PACKAGES+=uboot-lantiq
+#kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
diff --git a/target/linux/ifxmips/extract.py b/target/linux/ifxmips/extract.py
new file mode 100755 (executable)
index 0000000..91b4a57
--- /dev/null
@@ -0,0 +1,9 @@
+#!/usr/bin/python
+from sys import stdin, stdout
+while True:
+       c = stdin.read(2)
+       if len(c) < 2:
+               break
+       n1, n2 = ord(c[0]), ord(c[1])
+       stdout.write(chr(((n2 & 15) << 4) + ((n2 & 240) >> 4)))
+       stdout.write(chr(((n1 & 15) << 4) + ((n1 & 240) >> 4)))
diff --git a/target/linux/ifxmips/extract.sh b/target/linux/ifxmips/extract.sh
new file mode 100755 (executable)
index 0000000..4024969
--- /dev/null
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+DIR="$1/"
+FILE="$1/$2"
+
+echo "This tool downloads the arcor a800 firmware release and extracts the voip firmware for the danube."
+echo "Please only do so if it is legal in your country"
+
+[ ! -f ${FILE} ] && {
+       echo ${FILE} is missing
+       exit 1
+}
+
+[ ! -f ${DIR}bbd.crypt ] && {
+       dd if=${FILE} of=${DIR}bbd.crypt bs=1 skip=104 count=1472302
+}
+
+[ ! -f ${DIR}dsl_a.bin ] && {
+       dd if=${FILE} of=${DIR}dsl1.lzma bs=1 skip=2168832 count=150724
+       lzma d ${DIR}dsl2.lzma ${DIR}dsl_a.bin
+}
+
+[ ! -f ${DIR}dsl_b.bin ] && {
+       dd if=${FILE} of=${DIR}dsl2.lzma bs=1 skip=2320384 count=148343
+       lzma d ${DIR}dsl1.lzma ${DIR}dsl_b.bin
+}
+
+[ ! -f ${DIR}voip.bin ] && {
+       dd if=${FILE} of=${DIR}voip.lzma bs=1 skip=2468864 count=452105
+       lzma d ${DIR}voip.lzma ${DIR}voip.bin
+}
+exit 0
+
+# get lzma offsets
+# hexdump -C arcor_A800_452CPW_FW_1.02.206\(20081201\).bin | grep "5d 00 00 80"
+# hexdump -C arcor_A800_452CPW_FW_1.02.206\(20081201\).bin | grep "00 d5 08 00"
index 9710645b9962e858fe21c55efa3cf6442b7f8525..c330be6344ab38c57995e9b282b96b4e666ff69c 100644 (file)
@@ -1 +1 @@
-obj-y := reset.o prom.o setup.o irq.o dma-core.o pmu.o board.o clock.o gpio.o
+obj-y := reset.o prom.o setup.o irq.o dma-core.o pmu.o board.o clock.o gpio.o timer.o
index d05df2283cf8313d95486fdd4a0a56207d2b4bbb..31e606c85a0f53d71f5db9593a231e5ab3430292 100644 (file)
 #include <asm/irq.h>
 #include <asm/div64.h>
 
-#include <asm/ifxmips/ifxmips.h>
-#include <asm/ifxmips/ifxmips_irq.h>
-#include <asm/mach-ifxmips/cgu.h>
-#include <asm/ifxmips/ifxmips_gptu.h>
-#include <asm/ifxmips/ifxmips_pmu.h>
+#include <ifxmips.h>
+#include <ifxmips_irq.h>
+#include <ifxmips_cgu.h>
+#include <ifxmips_gptu.h>
+#include <ifxmips_pmu.h>
 
 #define MAX_NUM_OF_32BIT_TIMER_BLOCKS  6