sibyte image generation cleanup
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 May 2009 11:14:06 +0000 (11:14 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 May 2009 11:14:06 +0000 (11:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16046 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sibyte/image/Makefile

index 58c6bbd24b585858c9eb2ecfc191c6b66866527d..d29a01900de1f1c686270b9dd99521ea80d8c507 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,14 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-#define Image/Prepare
-#      cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
-#endef
-
 define Image/BuildKernel
        cp $(LINUX_DIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
+# uImage
+       dd if=$(KDIR)/vmlinux of=$(KDIR)/openwrt-$(BOARD)-vmlinux bs=64k conv=sync
+       mkimage -A mips -O linux -T kernel -a 0x80100000 -C none -e \
+               0x80100000 \
+               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -d $(KDIR)/openwrt-$(BOARD)-vmlinux $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
 define Image/Build
@@ -29,9 +31,8 @@ define Image/Build/jffs2-128k
 endef
 
 define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-       $(call Image/Build/slug,$(1))
 endef
 
 $(eval $(call BuildImage))