openwrt: honour gcc extra configuration flags
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:17 +0000 (06:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:17 +0000 (06:23 +0000)
Although the CONFIG_EXTRA_GCC_OPTIONS flag is available, it isn't used
anywhere.

This change adds the extra flag to both gcc configure stages.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9406 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile

index a326bb716f13cb3a0c04ae9cbd64449b9f3f0bac..d9e34af0bd03716ce9ed3d7d2257937b5a6461c0 100644 (file)
@@ -60,6 +60,7 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef
 define Stage1/Compile
@@ -91,6 +92,7 @@ define Stage2/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef