Added clinkc, an embedded UPnP library for audio/video equipments (mediaserver and...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jan 2006 22:38:12 +0000 (22:38 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jan 2006 22:38:12 +0000 (22:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3048 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/clinkc/Config.in [new file with mode: 0644]
package/clinkc/Makefile [new file with mode: 0644]
package/clinkc/ipkg/clinkc.control [new file with mode: 0644]

index ce27676ed1fe6fd9ad6b58d2dc8db58dffbe0099..488680ccf45e2243267b4b47fff9539d5296119b 100644 (file)
@@ -178,6 +178,7 @@ source "package/libamsel/Config.in"
 source "package/libao/Config.in"
 source "package/libart/Config.in"
 source "package/libcli/Config.in"
+source "package/clinkc/Config.in"
 source "package/curl/Config.in" # libcurl
 source "package/libdaemon/Config.in"
 source "package/libdb/Config.in"
index 0f1645873e7caff2da37e5aaadad1d91014e9db7..4f3cb2ae59960fe36d36cb4314be63f00db4b206 100644 (file)
@@ -21,6 +21,7 @@ package-$(BR2_PACKAGE_BWM) += bwm
 package-$(BR2_PACKAGE_CGILIB) += cgilib
 package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
+package-$(BR2_PACKAGE_CLINKC) += clinkc
 package-$(BR2_PACKAGE_COLLECTD) += collectd
 package-$(BR2_PACKAGE_CUPS) += cups
 package-$(BR2_COMPILE_CURL) += curl
@@ -268,6 +269,7 @@ arpd-compile: libpcap-compile libdnet-compile libevent-compile
 arpwatch-compile: libpcap-compile
 avahi-compile: libdaemon-compile expat-compile libgdbm-compile
 bind-compile: openssl-compile
+clinkc-compile: expat-compile
 curl-compile: openssl-compile zlib-compile
 cyrus-sasl-compile: openssl-compile
 deco-compile: ncurses-compile
diff --git a/package/clinkc/Config.in b/package/clinkc/Config.in
new file mode 100644 (file)
index 0000000..6805564
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CLINKC
+       prompt "clinkc............................ Embedded UPnP library"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBEXPAT
+       help
+               CyberLink for C is a UPnP library using C for small and embedded platforms.
+
+               http://sourceforge.net/projects/clinkc
+
diff --git a/package/clinkc/Makefile b/package/clinkc/Makefile
new file mode 100644 (file)
index 0000000..4669bb9
--- /dev/null
@@ -0,0 +1,63 @@
+# $Id: Makefile 1640 2005-08-13 20:32:32Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=clinkc
+PKG_VERSION:=101
+PKG_RELEASE:=1
+PKG_MD5SUM:=4c8ac54a15da47203a86daf77fbc2664
+
+PKG_SOURCE_URL:=@SF/clinkc/
+PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/CyberLinkC
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,CLINKC,clinkc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --datadir=/usr/share \
+               --includedir=/usr/include \
+               --infodir=/usr/share/info \
+               --libdir=/usr/lib \
+               --libexecdir=/usr/lib \
+               --localstatedir=/var \
+               --mandir=/usr/share/man \
+               --sbindir=/usr/sbin \
+               --sysconfdir=/etc \
+               --with-gnu-ld \
+       );
+       chmod +x $(PKG_BUILD_DIR)/config/install-sh
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_CLINKC):
+       cp -fpR $(PKG_INSTALL_DIR) $(IDIR_CLINKC)
+       $(RSTRIP) $(IDIR_CLINKC)
+       $(IPKG_BUILD) $(IDIR_CLINKC) $(PACKAGE_DIR)
+
diff --git a/package/clinkc/ipkg/clinkc.control b/package/clinkc/ipkg/clinkc.control
new file mode 100644 (file)
index 0000000..cf83587
--- /dev/null
@@ -0,0 +1,5 @@
+Package: clinkc
+Priority: optional
+Section: net
+Description: CyberLink for C is a UPnP library using C for small and embedded platforms.
+Priority: optional