fix a small bug in the unpack code
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Mar 2007 21:32:59 +0000 (21:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Mar 2007 21:32:59 +0000 (21:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6587 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/unpack.mk

index e195f316f6787fe9d3d025819319673b579e58b0..b8349c9ca46d13e9f4ecf7792f97d3a0f7e4d471 100644 (file)
@@ -42,7 +42,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
   endif
  
   # compatibility code for packages that set PKG_CAT
-  ifeq ($(strip $(PKG_CAT)$(PKG_UNPACK)),)
+  ifeq ($(strip $(PKG_UNPACK)),)
     # use existing PKG_CAT
     PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
     ifeq ($(PKG_CAT),unzip)