package uuidgen
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2008 01:29:32 +0000 (01:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2008 01:29:32 +0000 (01:29 +0000)
Package uuidgen utility. It is useful for other filesystem
utilities and miniupnpd.
There is no need to change the release.

Signed-off-by: Lubos Stanek (lubek) <lubek@lubek.name>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10350 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/e2fsprogs/Makefile

index f93cf4accab9e65866fddd16c3a6453e9a89e236..a30aea7ed85af93e30005d4d0e746c93bbdf02d7 100644 (file)
@@ -47,6 +47,19 @@ define Package/libuuid/description
  Library for generating DCE compatible Universally Unique Identifiers.
 endef
 
+define Package/uuidgen
+$(call Package/e2fsprogs)
+  DEPENDS:=libuuid
+  TITLE:=Command line utility to create a new UUID value
+endef
+
+define Package/uuidgen/description
+ uuidgen program creates a new universally unique identifier (UUID) 
+ using the libuuid library. The new UUID can reasonably be considered 
+ unique among all UUIDs created on the local system, and among UUIDs 
+ created on other systems in the past and in the future.
+endef
+
 define Package/libblkid
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
@@ -118,6 +131,11 @@ define Package/libuuid/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
 endef
 
+define Package/uuidgen/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uuidgen $(1)/usr/bin/
+endef
+
 define Package/libblkid/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
@@ -135,6 +153,7 @@ endef
 
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,libuuid))
+$(eval $(call BuildPackage,uuidgen))
 $(eval $(call BuildPackage,libblkid))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))