change x86 image generation handling to treat only olpc specially
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Nov 2009 19:49:25 +0000 (19:49 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Nov 2009 19:49:25 +0000 (19:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18441 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index 9dd7ae58779fb6499ac06b7aaa5c425b9b1e1c00..8768e7cbe6479e7ac29c74b8cd7c740bedb2ebe5 100644 (file)
@@ -1,6 +1,6 @@
 config X86_GRUB_IMAGES
     bool "Build GRUB images (Linux x86 or x86_64 host only)"
-    depends TARGET_x86_generic
+    depends !TARGET_x86_olpc
     depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS || TARGET_ROOTFS_ISO
        select PACKAGE_grub
     default y
index 699dcfe6abb9e7f6fc4c9c682f11006e7a43a50a..b412873c38404b63ca2c8344ad5e7f49e3168156 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 export PATH=$(TARGET_PATH):/sbin
 
-ifeq ($(CONFIG_TARGET_x86_generic),y)
+ifneq ($(CONFIG_TARGET_x86_olpc),y)
 BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
 ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
 #"))")) # fix vim's broken syntax highlighting
@@ -120,14 +120,13 @@ endif
 
 define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-ifeq ($(CONFIG_TARGET_x86_generic),y)
-       $(call Image/Prepare/grub)
-endif
 ifeq ($(CONFIG_TARGET_x86_olpc),y)
        $(call Image/Prepare/bootscript)
+else
+       $(call Image/Prepare/grub)
 endif
 endef
-  
+
 define Image/Build/squashfs
     $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef