fix verbose output with dash as /bin/sh
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 14:50:15 +0000 (14:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 14:50:15 +0000 (14:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8227 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/host.mk
include/verbose.mk

index 6703d90d61af7921cb81cec71141ef1364c52951..a039c9880b41e736106179974aba11f32aa99bda 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,8 @@ ifneq ($(OPENWRT_BUILD),1)
   export OPENWRT_BUILD:=1
   include $(TOPDIR)/include/toplevel.mk
 else
   export OPENWRT_BUILD:=1
   include $(TOPDIR)/include/toplevel.mk
 else
+  include $(TOPDIR)/include/host.mk
+
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
index cc0436e7b04b42fcd293243b96c02ce5b035810a..8b2e56ce510bf7c5d9325c755d82a5b6196c9bfc 100644 (file)
@@ -8,6 +8,7 @@
 -include $(TMP_DIR)/.host.mk
 
 export TAR
 -include $(TMP_DIR)/.host.mk
 
 export TAR
+TMP_DIR ?= $(TOPDIR)/tmp
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
index f18e9a2c7105257a7993f284b2220ea548e4280d..5ceaf9999c328dedd26eabaaaf10317654ad1f7c 100644 (file)
@@ -26,7 +26,7 @@ ifeq ($(IS_TTY),1)
 endif
 
 define MESSAGE
 endif
 
 define MESSAGE
-       echo -e "$(_Y)$(1)$(_N)" >&3
+       /bin/echo -e "$(_Y)$(1)$(_N)" >&3
 endef
 
 ifneq ($(KBUILD_VERBOSE),99)
 endef
 
 ifneq ($(KBUILD_VERBOSE),99)