Final updates to default configuration of ps3 petitboot sub-target
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 16:02:52 +0000 (16:02 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 16:02:52 +0000 (16:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14918 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
target/linux/ps3/Makefile
target/linux/ps3/petitboot/target.mk

index 5d8baeaeb60d8566ae57cabb422e303f727e4f65..baca4b5e792e66ee4971ae8fac4e6aef88c1b1fa 100644 (file)
@@ -15,6 +15,7 @@ DEVICE_TYPE?=router
 DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
+DEFAULT_PACKAGES.bootloader:=kexec-tools
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
index 2984019f937ffc82ed436d700c111476cdff7d95..4b2519befd6ca6ecf5bd72a2ec4540567cc50ce9 100644 (file)
@@ -12,6 +12,8 @@ BOARDNAME:=Sony PS3 Game Console
 MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
 
+DEVICE_TYPE=bootloader
+
 LINUX_VERSION:=2.6.28.8
 
 KERNEL_CC:=
index 5f16ba4e2371c917acbd9a356a89a50f9f6090a0..a3d84dde0343e5a7f380dc9714ee772655d8c13b 100644 (file)
@@ -1,7 +1,8 @@
 BOARDNAME:=Petitboot
-DEVICE_TYPE:=bootloader
 FEATURES:=fpu
 
+DEFAULT_PACKAGES+= dnsmasq
+
 define Target/Description
        Build Petitboot bootloader
 endef