[backfire] merge r29901
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jan 2012 20:54:50 +0000 (20:54 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jan 2012 20:54:50 +0000 (20:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29902 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile
package/hostapd/files/wpa_supplicant.sh

index d3de13710574f6b4fe77d009a0cfbf97abb6aa18..c60217f0e3ef2308b2bb5e976d87ea5416333677 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20111103
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20111103
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 1ab6c663e573bda96e6138a96a1b341773eec70b..9446202be3385793ee36fbb06d41cd04a8d130e2 100644 (file)
@@ -87,9 +87,11 @@ wpa_supplicant_setup_vif() {
                                        pairwise='pairwise=CCMP'
                                        group='group=CCMP'
                                        config_get identity "$vif" identity
                                        pairwise='pairwise=CCMP'
                                        group='group=CCMP'
                                        config_get identity "$vif" identity
+                                       config_get client_cert "$vif" client_cert
                                        config_get priv_key "$vif" priv_key
                                        config_get priv_key_pwd "$vif" priv_key_pwd
                                        identity="identity=\"$identity\""
                                        config_get priv_key "$vif" priv_key
                                        config_get priv_key_pwd "$vif" priv_key_pwd
                                        identity="identity=\"$identity\""
+                                       client_cert="client_cert=\"$client_cert\""
                                        priv_key="private_key=\"$priv_key\""
                                        priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
                                ;;
                                        priv_key="private_key=\"$priv_key\""
                                        priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
                                ;;
@@ -132,6 +134,7 @@ network={
        $group
        $eap_type
        $ca_cert
        $group
        $eap_type
        $ca_cert
+       $client_cert
        $priv_key
        $priv_key_pwd
        $phase2
        $priv_key
        $priv_key_pwd
        $phase2